解决树莓派语言包的一个错误

概述

我每次登录树莓派都会出现下面这个错误
manpath: can't set the locale; make sure $LC_* and $LANG are correct
而且中文显示会不正常,一开始我也不想去修正因为不影响正常使用,反正就是一个语言错误,今天无聊,就解决一下。其实很简单。

解决

首先安装语言包
sudo locale-gen "en_US.UTF-8"
之后重新设定语言
sudo dpkg-reconfigure locales
接着编辑配置文件
vim /etc/default/locale
加入
LC_ALL="en_US.UTF-8"
这样就好了,当然了你也可以使用raspi-config来设定,不过你要注意语言包有没有安装上,还有上面那个配置文件中有没有上面那句话

欢迎关注Bboysoul的博客www.bboy.app
Have Fun

欢迎关注我的其它发布渠道