树莓派安装go

简介

大学的时候在使用openfalcon的时候讲过这个东西,但是那时候是介绍open-falcon的,所以感觉不是很具体,所以今天在安装frp的时候也碰到了这个问题,我就具体的说下

安装go1.4

编译最新版本的go的时候一定要先编译安装go1.4,因为那个版本之前的go都是使用gcc编译的,之后的go都是使用go编译的,所以在安装最新的go之前要编译1.4的go

首先下载

wget https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz

解压编译安装

tar -zxvf go1.4-bootstrap-20171003.tar.gz

cd go/src/

./make.bash

cd ../../

mv go /usr/local/

export PATH=$PATH:/usr/local/go/bin

安装最新版本的go

首先下载最新版本的go

wget https://dl.google.com/go/go1.12.4.src.tar.gz

解压编译安装

tar -zxvf go1.12.4.src.tar.gz

cd go/src

export GOROOT_BOOTSTRAP=/usr/local/go/

./make.bash

查看下现在的go版本

go version

之后删除1.4版本的go

rm -rf /usr/local/go/

把新版本的go移动到这个路径

cd .. && mv go /usr/local/

最后添加环境变量

vim /etc/profile

加入

export PATH=$PATH:/usr/local/go/bin

source /etc/profile

最后验证一下go的版本

go version

欢迎关注Bboysoul的博客www.bboy.app

Have Fun

欢迎关注我的其它发布渠道