0%

概述

前几天迫不得已重装了系统,所以要重新安装一下python,我用的python版本管理工具是pyenv,大家都得知道一点的是大天朝的电信出口带宽等于断网,所以我用proxychains这个工具用来做代理执行pyenv的安装命令,没想到报错了,而且这个报错只有在使用proxychains来执行pyenv的时候才会发生

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
➜  ~  pyenv install 2.7.14
Downloading Python-2.7.14.tar.xz...
-> https://www.python.org/ftp/python/2.7.14/Python-2.7.14.tar.xz
Installing Python-2.7.14...

BUILD FAILED (Ubuntu 16.04 using python-build 20160602)

Inspect or clean up the working tree at /tmp/python-build.20170918160806.22886
Results logged to /tmp/python-build.20170918160806.22886.log

Last 10 log lines:
checking for getcwd... yes
checking for strdup... yes
checking for getpgrp... yes
checking for setpgrp... (cached) yes
checking for gettimeofday... yes
checking for major... yes
checking for getaddrinfo... yes
checking getaddrinfo bug... yes
Fatal: You must get working getaddrinfo() function.
       or you can specify "--disable-ipv6".

what the fuck ? 在线安装不可以那我离线安装还不行?

概述

ghost是基于nodejs构建的开源博客平台 网上有很多部署ghost博客的文章,包括ghost中文网,部署的方法很多,但是我觉得最方便的就是用ghost_cli去部署ghost,ghost-cli是1.0版本之后出现的新工具。简单来说就是它能够帮助我们更加方便地安装,启动,升级和管理我们的ghost-blog. 下面就来介绍这种部署的方式

简介

在中国的互联网环境下做一个程序员真的很难,电信出口带宽就像吃屎一样的慢,移动还好点 ,但是没办法,谁叫你是chinese 首先呢设置代理的话你得确保你的ss已经连接上了,之后下载polipo把socks5的代理转换成http和https代理,之后在终端设置一下就好了

简介

注意,伟大的GFW之内的土地已经不适合我生存,所以我需要把我的博客搬到外面去,然后我选择了Typecho这个博客系统,因为比较小巧,适合我这个穷学生,而且功能比较完善。废话不多说开始安装

简介

说实在的,作为一个人真的不应该图方便用安装脚本去安装lnmp环境的,因为这个环境的php等软件版本都把你固定死了,所以,现在我需要升级我的服务器上的php版本了,升级到什么版本呢?当然是最新版本

简介

Composer是 PHP 用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer 会帮你安装这些依赖的库文件。

简介

虽然自己的服务器平时没什么事情,也没什么人用,但是我还是很在意自己的流量的,所以就使用了vnstat来监控自己的服务器流量

简介

自己一直以来相搭建一个开源镜像站,一方面可以了解搭建镜像站的知识,一方面可以同步那些国内没有的linux发行版软件源,但是最主要的原因只是为了好玩